Weather Alert: Winter Weather Impacting Deliveries

Incident Report for Delivery Network PROD

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 11:33 CST

Monitoring

Dear Valued Customer,

Please be advised that Winter weather in the Midwestern and Northeastern U.S. may impact the processing, transportation and delivery of mail and packages.

Affected areas include:
Nebraska, Iowa, Wisconsin, Illinois, Ohio, Indiana, Michigan, Missouri and New York

We are closely monitoring the situation to minimize any disruption while prioritizing safety.

Thank you for your patience and understanding.

Stay safe,

ACI Partnership Team
Posted Dec 01, 2025 - 20:07 CST
This incident affected: Midwest (East North Central, West North Central) and Northeast (New England).